<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"21817424","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":4,"applicationTime":507,"agent":""}</script>
<script type="text/javascript">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</script>
<script>
  var googleAnalyticsId = "UA-81901317-1";
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
  ga('create', googleAnalyticsId, 'auto');
</script>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<title>PalmettoPreps.com  -  Geiger shows talent at Carolina Xposure</title>
<meta content='PalmettoPreps.com  -  Geiger shows talent at Carolina Xposure' property='og:title'>
<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-42736c1a7eb2a694d80bae23270ea1b0c5d5da44d33cc12c90aec89380ed21f5.css" />

<script src="https://cdn.rivals.com/production/assets/application-1192834571c64be74f40c174e62f4a16bd5be09f451ac0b083467411d00857c8.js"></script>
<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="XrA/glYulCwOVPQY61HPdWhci+Dm0OvPDmLULJ0VEuJ7qzO7J4n49tZZFtwB9iLqoYojXsEX+IxHXPgQUevZ0g==" />
<script type="application/javascript">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</script>

<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-273d00a84d0505fdc2d9beb1315850199c1ab215394a98be1a63372ca20207de.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-bbea1de48acc36b36c4ecbc46ec3289e31950d22f6370c08529de09bfece57b8.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://palmettopreps.rivals.com/news/geiger-shows-talent-at-carolina-xposure' property='og:url'>
<meta content='https://cdn.rivals.com/image/upload/f_auto,q_auto,t_thumbnail/fyrl5rhihujxjapsh0cu' property='og:image'>
<meta content="Spring Valley's Jalen Geiger turned in a strong performance in Charlotte over the weekend" property='og:description'>
<meta content='article' property='og:type'>
<meta content='2018-03-22 09:39:00 -0500' property='article:published_time'>
<meta content='2018-03-21 14:01:42 -0500' property='article:modified_time'>
<meta content='Article' property='article:section'>
<meta content='Jalen Geiger' property='article:tag'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-7404e8851b384e973afdb1115390a36947dbf5fe28a232d84e5c6908cd7705d5.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-6648de94c2c3e41f6513ac5c0467ffd19f7c02e65a0fc936f1a9982f3ed748c8.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-8f5bdbc6adbf0c5fba8e0fcac9577fd4d33e68420787ee56f609e500a58b921f.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-6fe5688966b66892f842e9c4a9024cbca3c4cb1924d64c8d62a0ddbf47fc68e9.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-0372b897e5d8e989c1aeb7b4c620e3a3d1d7ce7406faf9ba0bfa6848c33b920a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-783a1158ba513dae40547a7466182cab45cdd11c5d875c25c4c47b5da51c027e.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-8241e0d11a6d3b792f7ff1728e23e8d3d4c06a582e090d29c3dd0e3c075a9105.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-7882a3d3bb9b9b3b702c4e642b2c161e2efc0e47150051764e987199e58bd8c0.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-07196b8cded86c2a4bf5c14f585d72da8fb6c20c3246efc59fa27678059c9940.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-8f32636231ae820b22a672b74aedfff6c3106cccaeb865a002330d943f6910f4.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-c81451fd0d87890abd08b9db0a795d10339bb7c12662e9e9f3c15ac330bdaf9a.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-8df131d801eebf824632ce95b824704d0a928c3cf453c5222cbe555c87b1eb0f.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-728b6833bcd8ec9ff9fa15aba3595de5b9df51530f29547457c749719f1f0b8d.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-e7e88ca08f6e98bf706fceb62b57f86c338da64c83252bcc5a8b2f35fd89f191.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-5ab6bada83e2c243aec32edcf5f419498d7897c6cfcca56ba6b1a16c7091f14d.json' rel='manifest'>
<script>
  var _sf_async_config = _sf_async_config || {};
  var subdomain = "palmettopreps.rivals.com";
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63621; // ACCOUNT NUMBER
  _sf_async_config.domain = subdomain;
  _sf_async_config.flickerControl = false;
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>

</head>
<body class='palmettopreps contents-show_updated_layout' ng-app='rivals'>
<script>
  angular.module('rivals').run(function(googleAnalyticsService) {
    googleAnalyticsService.setGaClientId();
    })
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  @media screen and (max-width: 1023px) {
    .palmettopreps #programming > h1 {
      background-color: #001cc8 !important; } }
  .palmettopreps > header .notification-link .count-container {
    background-color: #001cc8 !important; }
  .palmettopreps > header .wrapper-container {
    background-color: #001cc8 !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .palmettopreps > header .wrapper-container {
        border-bottom: 5px solid #f8f8f8 !important; } }
  .palmettopreps > header .invalid-email-banner {
    background-color: #001cc8;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .palmettopreps > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .palmettopreps > header .invalid-email-banner a:hover {
      color: #f8f8f8; }
  @media screen and (max-width: 767px) {
    .palmettopreps > header .mobile-header {
      background-color: #f8f8f8 !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  .palmettopreps > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  .palmettopreps > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  .palmettopreps > header .second-nav {
    background-color: white !important; }
  @media screen and (max-width: 1023px) {
    .palmettopreps > header .nav-row > ul,
    .palmettopreps > header .third-nav {
      background-color: white !important; }
    .palmettopreps > header .dropdown-toggle > i.fa {
      color: #001cc8 !important; } }
  .palmettopreps > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #001cc8; }
  
  .site-primary-font-color {
    color: #001cc8; }
  
  .site-primary-background-color {
    background-color: #001cc8; }
  
  .site-secondary-font-color {
    color: #f8f8f8; }
  
  .site-secondary-background-color {
    background-color: #f8f8f8; }
  
  :root {
    --outbrain-primary-color: #001cc8;
    --outbrain-secondary-color: #f8f8f8; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-controller='NavController as ctrl' role='navigation'>
  <div class='wrapper-container'>
    <div class='wrapper logo-row'>
      <a alt="Rivals" href="//Rivals.rivals.com"><div class='rivals-logo-navbar-white'></div>
      </a>
      <a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
      <a alt="South Carolina HS Sports" class="school-header" href="//palmettopreps.rivals.com"><span class='header-text'>
        PalmettoPreps.com
      </span>
      </a>
      <div class='nav-right-controls'>
        <div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
          <span>Join the Rivals community!</span>
          <a class='btn' ng-href='{{ ctrl.subscribePath }}'>Subscribe</a>
        </div>
        <rv-universal-search></rv-universal-search>
        <rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
        <rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && (ctrl.isDesktop || ctrl.isTablet)'></rv-forums-info>
      </div>
    </div>
  </div>
  <div class='mobile-header'></div>
  <rv-header-alert class='alert-nav' scroll-min='40'></rv-header-alert>
  <hr>
  <div class='nav-row-container'>
    <div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="//palmettopreps.rivals.com">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;palmettopreps&#39;" limit="8"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="//palmettopreps.rivals.com">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;palmettopreps&#39;" limit="4"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
      <a ng-href='{{ctrl.userProfileEditPath}}'>
        Your account has an invalid email address. Please update it here.
      </a>
    </div>
  </div>
</nav>
</header>
<div class='alert-placeholder'>
<rv-header-alert></rv-header-alert>
</div>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script>
  YAHOO.i13n.WEBWORKER_FILE = "js/rivals/analytics/rapidworker-1.2.js";
  
  var rapid = new YAHOO.i13n.Rapid({
    spaceid: 2022719679,
    ywa: {
      project_id: 10002066977754,
      document_group: 'content',
      member_id: 0
    },
    nol: 1,
    client_only: 1
  });
</script>

<script>
  var contentTitle = "Geiger shows talent at Carolina Xposure"
</script>
<meta content='summary_large_image' name='twitter:card'>
<meta content='PalmettoPrepsSC' name='twitter:site'>
<meta content='Geiger shows talent at Carolina Xposure' name='twitter:title'>
<meta content="Spring Valley's Jalen Geiger turned in a strong performance in Charlotte over the weekend" name='twitter:description'>
<meta content='https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/fyrl5rhihujxjapsh0cu' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init([{"id":1905608,"title":"Robinson flying under the radar","slug":"robinson-flying-under-the-radar-1","kind":"free","site_id":128,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-19T10:32:29.475-05:00","summary":"Spartanburg senior running back Zykamren Robinson has the potential to be the top running back in the state.","deleted":false,"author_name":"Will Helms","author_title":"Staff Writer","permalink":"https://palmettopreps.rivals.com/news/robinson-flying-under-the-radar-1","site_name":"PalmettoPreps.com","type":"Content","programming":[128],"associated_links":[{"id":4526,"url":"https://palmettopreps.rivals.com/news/sc-high-school-football-top-2020-players","display_text":"Top 2020 football players","content_id":1905608,"created_at":"2018-03-21T15:36:48.268-05:00","updated_at":"2018-03-21T15:36:48.268-05:00","setting_id":null,"ordinality":1},{"id":4527,"url":"https://palmettopreps.rivals.com/news/welcome-to-palmettopreps-com-","display_text":"Learn more about our website","content_id":1905608,"created_at":"2018-03-21T15:36:48.271-05:00","updated_at":"2018-03-21T15:36:48.271-05:00","setting_id":null,"ordinality":2}]},{"id":1902540,"title":"SCBCA inducts four into Hall of Fame class","slug":"scbca-set-to-induct-four-into-hall-of-fame-class","kind":"free","site_id":128,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-21T14:03:26.146-05:00","summary":"The SC Basketball Coaches Association has announced its Hall of Fame Class for 2016.  Inductees include Dorothy Fortune","deleted":false,"author_name":"Chris Clark","author_title":"Publisher","permalink":"https://palmettopreps.rivals.com/news/scbca-set-to-induct-four-into-hall-of-fame-class","site_name":"PalmettoPreps.com","type":"Content","programming":[],"associated_links":[{"id":4521,"url":"https://palmettopreps.rivals.com/subscriptions/new","display_text":"Subscribe today to PalmettoPreps!","content_id":1902540,"created_at":"2018-03-21T14:03:26.994-05:00","updated_at":"2018-03-21T14:03:26.994-05:00","setting_id":null,"ordinality":1},{"id":4522,"url":"https://palmettopreps.rivals.com/news/welcome-to-palmettopreps-com-","display_text":"Learn more about our website","content_id":1902540,"created_at":"2018-03-21T14:03:26.996-05:00","updated_at":"2018-03-21T14:03:26.996-05:00","setting_id":null,"ordinality":2}]},{"id":1906011,"title":"Former Westwood receiver Vyncint Smith talks Pro Day","slug":"former-westwood-receiver-vyncint-smith-talks-pro-day","kind":"free","site_id":128,"sport":"football","news_type":"team","content_type":"Content::Video","live_at":"2018-03-20T13:11:33.763-05:00","summary":"Limestone senior and former Westwood receiver Vyncint Smith talks about his journey to Pro Day ahead of the NFL Draft.","deleted":false,"author_name":"Will Helms","author_title":"Staff Writer","permalink":"https://palmettopreps.rivals.com/news/former-westwood-receiver-vyncint-smith-talks-pro-day","site_name":"PalmettoPreps.com","type":"Content","programming":[],"associated_links":[{"id":3028,"url":"https://scvarsity.forums.rivals.com/forums/premium-all-sports-message-board.10/","display_text":"PREMIUM ALL SPORTS MESSAGE BOARD","content_id":null,"created_at":"2017-11-01T09:23:46.019-05:00","updated_at":"2017-11-01T09:23:46.019-05:00","setting_id":20,"ordinality":1},{"id":3029,"url":"https://scvarsity.rivals.com/subscriptions/new","display_text":"SUBSCRIBE TODAY!","content_id":null,"created_at":"2017-11-01T09:26:36.669-05:00","updated_at":"2017-11-01T09:26:36.669-05:00","setting_id":20,"ordinality":2}]},{"id":1905785,"title":"Ramon Robinson named 2018 Humanitarian of the Year","slug":"ramon-robinson-named-2018-humanitarian-of-the-year","kind":"free","site_id":128,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-19T17:16:29.335-05:00","summary":"Coach Ramon Robinson named SC Football Hall of Fame 2018 Humanitarian of the Year.","deleted":false,"author_name":"Wes Mitchell","author_title":"PalmettoPreps.com","permalink":"https://palmettopreps.rivals.com/news/ramon-robinson-named-2018-humanitarian-of-the-year","site_name":"PalmettoPreps.com","type":"Content","programming":[],"associated_links":[{"id":3028,"url":"https://scvarsity.forums.rivals.com/forums/premium-all-sports-message-board.10/","display_text":"PREMIUM ALL SPORTS MESSAGE BOARD","content_id":null,"created_at":"2017-11-01T09:23:46.019-05:00","updated_at":"2017-11-01T09:23:46.019-05:00","setting_id":20,"ordinality":1},{"id":3029,"url":"https://scvarsity.rivals.com/subscriptions/new","display_text":"SUBSCRIBE TODAY!","content_id":null,"created_at":"2017-11-01T09:26:36.669-05:00","updated_at":"2017-11-01T09:26:36.669-05:00","setting_id":20,"ordinality":2}]},{"id":1903304,"title":"SC high school football:  Top 2020 players","slug":"sc-high-school-football-top-2020-players","kind":"free","site_id":128,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-12T11:23:07.393-05:00","summary":"The Palmetto State will feature plenty of talented football players in the 2020 class and we are compiling a list.","deleted":false,"author_name":"Chris Clark","author_title":"Publisher","permalink":"https://palmettopreps.rivals.com/news/sc-high-school-football-top-2020-players","site_name":"PalmettoPreps.com","type":"Content","programming":[],"associated_links":[{"id":3028,"url":"https://scvarsity.forums.rivals.com/forums/premium-all-sports-message-board.10/","display_text":"PREMIUM ALL SPORTS MESSAGE BOARD","content_id":null,"created_at":"2017-11-01T09:23:46.019-05:00","updated_at":"2017-11-01T09:23:46.019-05:00","setting_id":20,"ordinality":1},{"id":3029,"url":"https://scvarsity.rivals.com/subscriptions/new","display_text":"SUBSCRIBE TODAY!","content_id":null,"created_at":"2017-11-01T09:26:36.669-05:00","updated_at":"2017-11-01T09:26:36.669-05:00","setting_id":20,"ordinality":2}]},{"id":1902959,"title":"Three to watch from Barnwell","slug":"three-to-watch-from-barnwell","kind":"free","site_id":128,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-12T11:10:20.998-05:00","summary":"Two offensive linemen and a linebacker from the 2020 class are now on the radar.","deleted":false,"author_name":"Chris Clark","author_title":"Publisher","permalink":"https://palmettopreps.rivals.com/news/three-to-watch-from-barnwell","site_name":"PalmettoPreps.com","type":"Content","programming":[],"associated_links":[{"id":3028,"url":"https://scvarsity.forums.rivals.com/forums/premium-all-sports-message-board.10/","display_text":"PREMIUM ALL SPORTS MESSAGE BOARD","content_id":null,"created_at":"2017-11-01T09:23:46.019-05:00","updated_at":"2017-11-01T09:23:46.019-05:00","setting_id":20,"ordinality":1},{"id":3029,"url":"https://scvarsity.rivals.com/subscriptions/new","display_text":"SUBSCRIBE TODAY!","content_id":null,"created_at":"2017-11-01T09:26:36.669-05:00","updated_at":"2017-11-01T09:26:36.669-05:00","setting_id":20,"ordinality":2}]},{"id":1903291,"title":"RNE&#x0027;s Taylor Britt a standout at SC Hoops Festival","slug":"westwood-s-taylor-britt-a-standout-at-sc-hoops-festival","kind":"free","site_id":128,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-12T10:52:15.574-05:00","summary":"The Richland Northeast guard was one of the game MVPs for the Capital City Showcase.","deleted":false,"author_name":"Chris Clark","author_title":"Publisher","permalink":"https://palmettopreps.rivals.com/news/westwood-s-taylor-britt-a-standout-at-sc-hoops-festival","site_name":"PalmettoPreps.com","type":"Content","programming":[],"associated_links":[{"id":3028,"url":"https://scvarsity.forums.rivals.com/forums/premium-all-sports-message-board.10/","display_text":"PREMIUM ALL SPORTS MESSAGE BOARD","content_id":null,"created_at":"2017-11-01T09:23:46.019-05:00","updated_at":"2017-11-01T09:23:46.019-05:00","setting_id":20,"ordinality":1},{"id":3029,"url":"https://scvarsity.rivals.com/subscriptions/new","display_text":"SUBSCRIBE TODAY!","content_id":null,"created_at":"2017-11-01T09:26:36.669-05:00","updated_at":"2017-11-01T09:26:36.669-05:00","setting_id":20,"ordinality":2}]},{"id":1901954,"title":"Porter Gaud&#x0027;s Nesmith is Gatorade&#x0027;s POY in SC","slug":"porter-gaud-s-nesmith-is-gatorade-s-poy-in-sc","kind":"free","site_id":128,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-08T08:23:19.881-06:00","summary":"A Lowcountry standout has earned a substantial national honor.","deleted":false,"author_name":"Chris Clark","author_title":"Publisher","permalink":"https://palmettopreps.rivals.com/news/porter-gaud-s-nesmith-is-gatorade-s-poy-in-sc","site_name":"PalmettoPreps.com","type":"Content","programming":[],"associated_links":[{"id":3028,"url":"https://scvarsity.forums.rivals.com/forums/premium-all-sports-message-board.10/","display_text":"PREMIUM ALL SPORTS MESSAGE BOARD","content_id":null,"created_at":"2017-11-01T09:23:46.019-05:00","updated_at":"2017-11-01T09:23:46.019-05:00","setting_id":20,"ordinality":1},{"id":3029,"url":"https://scvarsity.rivals.com/subscriptions/new","display_text":"SUBSCRIBE TODAY!","content_id":null,"created_at":"2017-11-01T09:26:36.669-05:00","updated_at":"2017-11-01T09:26:36.669-05:00","setting_id":20,"ordinality":2}]},{"id":1901724,"title":"South Carolina Hoops Festival set to hit Columbia","slug":"south-carolina-hoops-festival-set-to-hit-columbia","kind":"free","site_id":128,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-07T13:33:16.220-06:00","summary":"The Capital City will be packed with SC high school basketball talent during a showcase event on Saturday.","deleted":false,"author_name":"Chris Clark","author_title":"Publisher","permalink":"https://palmettopreps.rivals.com/news/south-carolina-hoops-festival-set-to-hit-columbia","site_name":"PalmettoPreps.com","type":"Content","programming":[],"associated_links":[{"id":3028,"url":"https://scvarsity.forums.rivals.com/forums/premium-all-sports-message-board.10/","display_text":"PREMIUM ALL SPORTS MESSAGE BOARD","content_id":null,"created_at":"2017-11-01T09:23:46.019-05:00","updated_at":"2017-11-01T09:23:46.019-05:00","setting_id":20,"ordinality":1},{"id":3029,"url":"https://scvarsity.rivals.com/subscriptions/new","display_text":"SUBSCRIBE TODAY!","content_id":null,"created_at":"2017-11-01T09:26:36.669-05:00","updated_at":"2017-11-01T09:26:36.669-05:00","setting_id":20,"ordinality":2}]},{"id":1901594,"title":"Prospect capsule:  Alex Meredith","slug":"prospect-capsule-alex-meredith","kind":"free","site_id":128,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-07T12:59:28.620-06:00","summary":"One of the state&#x0027;s most productive players should be drawing more looks at the major college level.","deleted":false,"author_name":"Chris Clark","author_title":"Publisher","permalink":"https://palmettopreps.rivals.com/news/prospect-capsule-alex-meredith","site_name":"PalmettoPreps.com","type":"Content","programming":[],"associated_links":[{"id":3028,"url":"https://scvarsity.forums.rivals.com/forums/premium-all-sports-message-board.10/","display_text":"PREMIUM ALL SPORTS MESSAGE BOARD","content_id":null,"created_at":"2017-11-01T09:23:46.019-05:00","updated_at":"2017-11-01T09:23:46.019-05:00","setting_id":20,"ordinality":1},{"id":3029,"url":"https://scvarsity.rivals.com/subscriptions/new","display_text":"SUBSCRIBE TODAY!","content_id":null,"created_at":"2017-11-01T09:26:36.669-05:00","updated_at":"2017-11-01T09:26:36.669-05:00","setting_id":20,"ordinality":2}]},{"id":1901704,"title":"Record Book - South Carolina High School Soccer (SCHSL)","slug":"record-book-south-carolina-high-school-soccer-schsl-","kind":"free","site_id":128,"sport":"other sports","news_type":"team","content_type":"Content::Article","live_at":"2018-03-07T12:59:01.894-06:00","summary":"Opening the record book for team and individual history-makers in South Carolina high school soccer.","deleted":false,"author_name":"Chris Clark","author_title":"Publisher","permalink":"https://palmettopreps.rivals.com/news/record-book-south-carolina-high-school-soccer-schsl-","site_name":"PalmettoPreps.com","type":"Content","programming":[],"associated_links":[{"id":3028,"url":"https://scvarsity.forums.rivals.com/forums/premium-all-sports-message-board.10/","display_text":"PREMIUM ALL SPORTS MESSAGE BOARD","content_id":null,"created_at":"2017-11-01T09:23:46.019-05:00","updated_at":"2017-11-01T09:23:46.019-05:00","setting_id":20,"ordinality":1},{"id":3029,"url":"https://scvarsity.rivals.com/subscriptions/new","display_text":"SUBSCRIBE TODAY!","content_id":null,"created_at":"2017-11-01T09:26:36.669-05:00","updated_at":"2017-11-01T09:26:36.669-05:00","setting_id":20,"ordinality":2}]},{"id":1899404,"title":"Prospect capsule:  Akele Pauling","slug":"prospect-capsule-akele-pauling","kind":"premium","site_id":128,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-05T11:47:18.197-06:00","summary":"PalmettoPreps.com breaks down one of the state&#x0027;s top overall prospects in DB Akele Pauling.","deleted":false,"author_name":"Chris Clark","author_title":"Publisher","permalink":"https://palmettopreps.rivals.com/news/prospect-capsule-akele-pauling","site_name":"PalmettoPreps.com","type":"Content","programming":[],"associated_links":[{"id":3028,"url":"https://scvarsity.forums.rivals.com/forums/premium-all-sports-message-board.10/","display_text":"PREMIUM ALL SPORTS MESSAGE BOARD","content_id":null,"created_at":"2017-11-01T09:23:46.019-05:00","updated_at":"2017-11-01T09:23:46.019-05:00","setting_id":20,"ordinality":1},{"id":3029,"url":"https://scvarsity.rivals.com/subscriptions/new","display_text":"SUBSCRIBE TODAY!","content_id":null,"created_at":"2017-11-01T09:26:36.669-05:00","updated_at":"2017-11-01T09:26:36.669-05:00","setting_id":20,"ordinality":2}]},{"id":1900158,"title":"HOOPS:  State championship game results","slug":"hoops-state-championship-game-results","kind":"free","site_id":128,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-03T07:06:14.662-06:00","summary":"Four teams were crowned as state champions in boys and girls hoops on Friday night.","deleted":false,"author_name":"Chris Clark","author_title":"Publisher","permalink":"https://palmettopreps.rivals.com/news/hoops-state-championship-game-results","site_name":"PalmettoPreps.com","type":"Content","programming":[],"associated_links":[{"id":3028,"url":"https://scvarsity.forums.rivals.com/forums/premium-all-sports-message-board.10/","display_text":"PREMIUM ALL SPORTS MESSAGE BOARD","content_id":null,"created_at":"2017-11-01T09:23:46.019-05:00","updated_at":"2017-11-01T09:23:46.019-05:00","setting_id":20,"ordinality":1},{"id":3029,"url":"https://scvarsity.rivals.com/subscriptions/new","display_text":"SUBSCRIBE TODAY!","content_id":null,"created_at":"2017-11-01T09:26:36.669-05:00","updated_at":"2017-11-01T09:26:36.669-05:00","setting_id":20,"ordinality":2}]},{"id":1899409,"title":"Prospect capsule:  Tysheik Galloway","slug":"prospect-capsule-tysheik-galloway","kind":"premium","site_id":128,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-03-01T11:01:24.622-06:00","summary":"DT Tysheik Galloway continues to fly under the radar.  PalmettoPreps.com breaks down the big man&#x0027;s game and potential.","deleted":false,"author_name":"Chris Clark","author_title":"Publisher","permalink":"https://palmettopreps.rivals.com/news/prospect-capsule-tysheik-galloway","site_name":"PalmettoPreps.com","type":"Content","programming":[],"associated_links":[{"id":3028,"url":"https://scvarsity.forums.rivals.com/forums/premium-all-sports-message-board.10/","display_text":"PREMIUM ALL SPORTS MESSAGE BOARD","content_id":null,"created_at":"2017-11-01T09:23:46.019-05:00","updated_at":"2017-11-01T09:23:46.019-05:00","setting_id":20,"ordinality":1},{"id":3029,"url":"https://scvarsity.rivals.com/subscriptions/new","display_text":"SUBSCRIBE TODAY!","content_id":null,"created_at":"2017-11-01T09:26:36.669-05:00","updated_at":"2017-11-01T09:26:36.669-05:00","setting_id":20,"ordinality":2}]},{"id":1899287,"title":"Prospect capsule:  Jalen Geiger","slug":"prospect-capsule-jalen-geiger","kind":"premium","site_id":128,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-02-28T13:20:56.593-06:00","summary":"Spring Valley DB Jalen Geiger is capturing the attention of college coaches.  We break down his game.","deleted":false,"author_name":"Chris Clark","author_title":"Publisher","permalink":"https://palmettopreps.rivals.com/news/prospect-capsule-jalen-geiger","site_name":"PalmettoPreps.com","type":"Content","programming":[],"associated_links":[{"id":3028,"url":"https://scvarsity.forums.rivals.com/forums/premium-all-sports-message-board.10/","display_text":"PREMIUM ALL SPORTS MESSAGE BOARD","content_id":null,"created_at":"2017-11-01T09:23:46.019-05:00","updated_at":"2017-11-01T09:23:46.019-05:00","setting_id":20,"ordinality":1},{"id":3029,"url":"https://scvarsity.rivals.com/subscriptions/new","display_text":"SUBSCRIBE TODAY!","content_id":null,"created_at":"2017-11-01T09:26:36.669-05:00","updated_at":"2017-11-01T09:26:36.669-05:00","setting_id":20,"ordinality":2}]},{"id":1899148,"title":"PalmettoPreps.com&#x0027;s prospect form","slug":"palmettopreps-com-s-prospect-form","kind":"free","site_id":128,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-02-28T10:14:19.803-06:00","summary":"State of South Carolina student-athletes in any sport can fill out our prospect form.","deleted":false,"author_name":"Chris Clark","author_title":"Publisher","permalink":"https://palmettopreps.rivals.com/news/palmettopreps-com-s-prospect-form","site_name":"PalmettoPreps.com","type":"Content","programming":[],"associated_links":[{"id":3028,"url":"https://scvarsity.forums.rivals.com/forums/premium-all-sports-message-board.10/","display_text":"PREMIUM ALL SPORTS MESSAGE BOARD","content_id":null,"created_at":"2017-11-01T09:23:46.019-05:00","updated_at":"2017-11-01T09:23:46.019-05:00","setting_id":20,"ordinality":1},{"id":3029,"url":"https://scvarsity.rivals.com/subscriptions/new","display_text":"SUBSCRIBE TODAY!","content_id":null,"created_at":"2017-11-01T09:26:36.669-05:00","updated_at":"2017-11-01T09:26:36.669-05:00","setting_id":20,"ordinality":2}]},{"id":1898782,"title":"PODCAST:  SC Coaches break down state finals","slug":"podcast-sc-coaches-break-down-state-finals","kind":"free","site_id":128,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-02-27T11:24:10.058-06:00","summary":"Two prominent high school hoops coaches break down the upcoming state championship games in Columbia.","deleted":false,"author_name":"Chris Clark","author_title":"Publisher","permalink":"https://palmettopreps.rivals.com/news/podcast-sc-coaches-break-down-state-finals","site_name":"PalmettoPreps.com","type":"Content","programming":[],"associated_links":[{"id":3028,"url":"https://scvarsity.forums.rivals.com/forums/premium-all-sports-message-board.10/","display_text":"PREMIUM ALL SPORTS MESSAGE BOARD","content_id":null,"created_at":"2017-11-01T09:23:46.019-05:00","updated_at":"2017-11-01T09:23:46.019-05:00","setting_id":20,"ordinality":1},{"id":3029,"url":"https://scvarsity.rivals.com/subscriptions/new","display_text":"SUBSCRIBE TODAY!","content_id":null,"created_at":"2017-11-01T09:26:36.669-05:00","updated_at":"2017-11-01T09:26:36.669-05:00","setting_id":20,"ordinality":2}]},{"id":1898485,"title":"Carolina Grind tryouts feature standout performers, hidden gems","slug":"carolina-grind-tryouts-feature-standout-performers-hidden-gems","kind":"premium","site_id":128,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-02-26T12:43:44.940-06:00","summary":"Several Palmetto State prospects shined at Carolina Grind&#x0027;s 7-on-7 training session last weekend.","deleted":false,"author_name":"Chris Clark","author_title":"Publisher","permalink":"https://palmettopreps.rivals.com/news/carolina-grind-tryouts-feature-standout-performers-hidden-gems","site_name":"PalmettoPreps.com","type":"Content","programming":[],"associated_links":[{"id":3028,"url":"https://scvarsity.forums.rivals.com/forums/premium-all-sports-message-board.10/","display_text":"PREMIUM ALL SPORTS MESSAGE BOARD","content_id":null,"created_at":"2017-11-01T09:23:46.019-05:00","updated_at":"2017-11-01T09:23:46.019-05:00","setting_id":20,"ordinality":1},{"id":3029,"url":"https://scvarsity.rivals.com/subscriptions/new","display_text":"SUBSCRIBE TODAY!","content_id":null,"created_at":"2017-11-01T09:26:36.669-05:00","updated_at":"2017-11-01T09:26:36.669-05:00","setting_id":20,"ordinality":2}]},{"id":1894597,"title":"HOOPS:  State championships set for weekend","slug":"schedule-results-for-sc-hoops-playoffs","kind":"free","site_id":128,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-02-26T08:15:00.160-06:00","summary":"An updated look at the playoff picture for boys and girls high school hoops in the state of SC.","deleted":false,"author_name":"Chris Clark","author_title":"Publisher","permalink":"https://palmettopreps.rivals.com/news/schedule-results-for-sc-hoops-playoffs","site_name":"PalmettoPreps.com","type":"Content","programming":[],"associated_links":[{"id":3926,"url":"https://scvarsity.forums.rivals.com/threads/what-is-palmettopreps-com.10184/#other-forums.8","display_text":"What is PalmettoPreps.com?","content_id":1894597,"created_at":"2018-02-19T07:40:05.092-06:00","updated_at":"2018-02-19T07:40:05.092-06:00","setting_id":null,"ordinality":1},{"id":3927,"url":"https://palmettopreps.rivals.com/subscriptions/new","display_text":"Subscribe and support today!","content_id":1894597,"created_at":"2018-02-19T07:40:05.095-06:00","updated_at":"2018-02-19T07:40:05.095-06:00","setting_id":null,"ordinality":2}]},{"id":1897521,"title":"Swansea&#x0027;s McNeal leads team to Lower State finals","slug":"swansea-s-mcneal-leads-team-to-upper-state-finals","kind":"premium","site_id":128,"sport":"football","news_type":"recruiting","content_type":"Content::Article","live_at":"2018-02-23T08:03:10.541-06:00","summary":"Swansea guard Danae McNeal pulls no punches when discussing her teams&#x0027; current season.\"We started off a little rough,","deleted":false,"author_name":"Chris Clark","author_title":"Publisher","permalink":"https://palmettopreps.rivals.com/news/swansea-s-mcneal-leads-team-to-upper-state-finals","site_name":"PalmettoPreps.com","type":"Content","programming":[],"associated_links":[{"id":3028,"url":"https://scvarsity.forums.rivals.com/forums/premium-all-sports-message-board.10/","display_text":"PREMIUM ALL SPORTS MESSAGE BOARD","content_id":null,"created_at":"2017-11-01T09:23:46.019-05:00","updated_at":"2017-11-01T09:23:46.019-05:00","setting_id":20,"ordinality":1},{"id":3029,"url":"https://scvarsity.rivals.com/subscriptions/new","display_text":"SUBSCRIBE TODAY!","content_id":null,"created_at":"2017-11-01T09:26:36.669-05:00","updated_at":"2017-11-01T09:26:36.669-05:00","setting_id":20,"ordinality":2}]},{"id":1897526,"title":"Spring Valley Viking Cup updates","slug":"spring-valley-viking-cup-updates","kind":"free","site_id":128,"sport":"other sports","news_type":"team","content_type":"Content::Article","live_at":"2018-02-23T07:56:11.799-06:00","summary":"A girls soccer tournament featuring 32 of the state&#x0027;s top teams is underway in the Midlands.","deleted":false,"author_name":"Chris Clark","author_title":"Publisher","permalink":"https://palmettopreps.rivals.com/news/spring-valley-viking-cup-updates","site_name":"PalmettoPreps.com","type":"Content","programming":[],"associated_links":[{"id":4005,"url":"https://palmettopreps.rivals.com/news/swansea-s-mcneal-leads-team-to-upper-state-finals","display_text":"HOOPS: Swansea&#x0027;s Danae McNeal ","content_id":1897526,"created_at":"2018-02-23T08:02:56.135-06:00","updated_at":"2018-02-23T08:02:56.135-06:00","setting_id":null,"ordinality":1},{"id":4006,"url":"https://palmettopreps.rivals.com/news/welcome-to-palmettopreps-com-","display_text":"What is PalmettoPreps?","content_id":1897526,"created_at":"2018-02-23T08:02:56.138-06:00","updated_at":"2018-02-23T08:02:56.138-06:00","setting_id":null,"ordinality":2}]},{"id":1896820,"title":"Day 2 results - Capital City Cup","slug":"capital-city-cup-kicks-off-tonight","kind":"free","site_id":128,"sport":"other sports","news_type":"team","content_type":"Content::Article","live_at":"2018-02-22T07:13:03.936-06:00","summary":"Results and information from a premier soccer tournament in the state.","deleted":false,"author_name":"Chris Clark","author_title":"Publisher","permalink":"https://palmettopreps.rivals.com/news/capital-city-cup-kicks-off-tonight","site_name":"PalmettoPreps.com","type":"Content","programming":[],"associated_links":[{"id":3960,"url":"https://palmettopreps.rivals.com/subscriptions/new","display_text":"Subscribe today to PalmettoPreps!","content_id":1896820,"created_at":"2018-02-21T12:06:13.726-06:00","updated_at":"2018-02-21T12:06:13.726-06:00","setting_id":null,"ordinality":1},{"id":3028,"url":"https://scvarsity.forums.rivals.com/forums/premium-all-sports-message-board.10/","display_text":"PREMIUM ALL SPORTS MESSAGE BOARD","content_id":null,"created_at":"2017-11-01T09:23:46.019-05:00","updated_at":"2017-11-01T09:23:46.019-05:00","setting_id":20,"ordinality":1}]}], nil, 128, nil, true); subdomain = &#x0027;palmettopreps&#x0027;; aolPlayerId = &#x0027;58e686759efa8936610b8215&#x0027;; aolCompanyId = &#x0027;58e68374c7480e728bcc385f&#x0027;'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>
<div class='article-container new'>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header news-header' style='background: #001cc8'>
Ticker
</div>
<div class='news' ng-repeat='content in newsList()'>
<div class='article' ng-if='content.type === "Content"'>
<div class='forum-icon' ng-if='forumThread(content.content_type)'></div>
<a class='title' href='{{content.permalink}}' ng-class="{'indent': content.kind === 'premium'}">
<div ng-cloak>{{content.title}}</div>
</a>
<div class='byline'>
<div class='premium-icon' ng-if='content.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='link-icon' ng-if='link(content.content_type)'><?xml version="1.0" encoding="utf-8"?>
<!-- Generator: Adobe Illustrator 19.1.0, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->

<svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" x="0px" y="0px" viewbox="0 0 16 12.2" enable-background="new 0 0 16 12.2" xml:space="preserve">
  <path id="XMLID_228_" fill="#0A4EA3" d="M9.1,8.8C8.3,10,7,10.7,5.5,10.7c-2.4,0-4.3-1.9-4.3-4.3s1.9-4.3,4.3-4.3
      c1.4,0,2.6,0.7,3.4,1.7h1.2C9.2,2.3,7.5,1.2,5.5,1.2c-2.9,0-5.3,2.4-5.3,5.3s2.4,5.3,5.3,5.3c2,0,3.8-1.2,4.7-2.9H9.1z"></path>
  <polygon id="XMLID_229_" fill="#0A4EA3" points="16.2,6.1 13.8,3.7 13.8,6.2 5.8,6.2 5.8,7.2 13.8,7.2 13.8,8.6 	"></polygon>
</svg>
</div>
<time datetime='{{content.live_at}}' ng-cloak>
{{timeAgo(content.live_at)}}
</time>
<a class='edit-article' href='/publishing/contents/{{content.id}}/edit' ng-show='$parent.isPublisher'>Edit</a>
</div>
</div>
<div class='tweet' ng-if='content.type === "Tweet"'>
<div class='tweet-icon'></div>
<a class='title' href='{{content.tweet_url}}' target='_blank'>
<div ng-bind-html='content.text_news_feed'></div>
</a>
</div>
</div>
</div>

<div class='side-rail-meta lrec-ad' ng-if="showLRECad('leftrail-below-ticker')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<div class='side-rail-meta lrec-ad2'>
<div class='side-rail-box'>
<div id='boxLREC2'>
<div id='tgtLREC2'></div>
</div>
</div>
</div>

<rv-homepage-forums ad-referer='https://palmettopreps.rivals.com/news/geiger-shows-talent-at-carolina-xposure' background-color='#001cc8' base-api-url='https://palmettopreps.forums.rivals.com/' homepage='false' message-board-url='scvarsity.forums.rivals.com' pub-ad='null' size='size' space-id='2022719679' subscribed-user='subscribedUser'></rv-homepage-forums>


<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>
</div>
</div>
<div class='article-display-wrapper'>
<div class='new-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://palmettopreps.rivals.com/news/geiger-shows-talent-at-carolina-xposure/printable' site-name='PalmettoPreps.com'></rv-share-links>
</div>
<span class='article-header-age' ng-cloak>{{ timeAgo('2018-03-22 09:39:00 -0500') }}</span>
<span class='article-header-sport'>football</span>
<a class='edit-article updated-article-page' href='{{editPath(subdomain)}}//publishing/contents/1905899/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h2 class='article-title'>Geiger shows talent at Carolina Xposure</h2>
<div class='header-image'><figure class='article-image'>
<div class='blurred-image'>
<div class='background' style='background-image: url(https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/fyrl5rhihujxjapsh0cu)'></div>
<img src="https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/fyrl5rhihujxjapsh0cu" alt="Fyrl5rhihujxjapsh0cu" />
</div>
<figcaption class='image-caption'></figcaption>
<div class='image-credit'></div>
</figure>
</div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<span>
<span class='title-sm'>
Will Helms
&bull;
</span>
<span class='type-sm'>PalmettoPreps.com</span>
<div class='type-sm'>
<a href='//twitter.com/whelms21' target='_blank'>@whelms21</a>
</div>
</span>
</div>
<div class='vertical-align link-button' ng-click='authorBio()' ng-cloak>
<div class='caret-down' ng-cloak ng-show='!expandProfile'></div>
<div class='caret-up' ng-cloak ng-show='expandProfile'></div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
<span>
<span class='title-sm'>Staff Writer</span>
</span>
<script async charset='utf-8' src='//platform.twitter.com/widgets.js'></script>
<a class='twitter-follow-button' data-show-count='false' data-show-screen-name='false' data-size='large' href='//twitter.com/whelms21'></a>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>

</div>
</div>
</div>
<div class='mobile-links' ng-cloak ng-if='isMobile'>
<div class='article-subheader'>
Related
</div>
<slick in-view='isInView($inview)' settings='slickConfig'>
<div ng-repeat='link in [{"id":4520,"url":"https://palmettopreps.forums.rivals.com/forums/palmettopreps-premium-forum.10/","display_text":"PREMIUM FORUMS","content_id":1905899,"created_at":"2018-03-21T14:01:42.795-05:00","updated_at":"2018-03-21T14:01:42.795-05:00","setting_id":null,"ordinality":1}]'>
<a ng-href='{{link.url}}' target='_blank'>{{ link.display_text }}</a>
</div>
</slick>
</div>
<div class='desktop-links' ng-cloak ng-if='!isMobile'>
<div class='article-subheader'>
Related
</div>
<span ng-repeat='link in [{"id":4520,"url":"https://palmettopreps.forums.rivals.com/forums/palmettopreps-premium-forum.10/","display_text":"PREMIUM FORUMS","content_id":1905899,"created_at":"2018-03-21T14:01:42.795-05:00","updated_at":"2018-03-21T14:01:42.795-05:00","setting_id":null,"ordinality":1}]'>
<a class='type-sm' ng-href='{{link.url}}' target='_blank'>
{{ link.display_text }}
</a>
<span class='link-divider' ng-if='!$last'>
|
</span>
</span>
</div>

<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><div class='st__content-block st__content-block--text article-text'>
<p><a href="https://palmettopreps.rivals.com/news/welcome-to-palmettopreps-com-">* Learn more about PalmettoPreps.com! *</a><br></p><p><a href="https://n.rivals.com/content/prospects/2019/jalen-geiger-199385">Jalen Geiger</a> joined over 300 prospects from North and South Carolina in Charlotte Saturday for the third annual Carolina Xposure Showcase. At day’s end, the 6-foot-1, 180-pounder emerged as the top defensive back in attendance.</p><p>Geiger locked down opposing receivers in one-on-ones and posted solid 40 times, both hovering around the 4.5 range.</p><p>Geiger is a long defensive back with good hips and the ability to close ground quickly. Geiger has room for improvement, but is putting in work in the training room this offseason.</p><p>“I'm really focusing on my flexibility this offseason,” Geiger said. “Of course I want to get faster and stronger and just continue to work on my craft at the [defensive back] position.”</p><p>Also See: <a href="https://palmettopreps.rivals.com/news/robinson-flying-under-the-radar-1">Spartanburg’s Robinson takes home MVP honors</a> </p><p>The rising senior from Spring Valley is one of several talented defensive backs from the Midlands. He has the potential to play several secondary positions, but I believe he projects as a safety at the next level. What he lacks in lateral quickness, he makes up for in range, with the top-end speed and length to recover quickly.</p><p>Geiger plans to hit the camp circuit in the early summer months to improve his stock, with a Rivals 3-Stripe stop planned in Atlanta.</p><p>Heading into his senior season, Geiger is garnering interest from several bigger programs, even if the marquis offers have not yet come. Holding offers from Ball State, Liberty and Kent State, Geiger is talking to Clemson, Miami (OH), NC State and East Carolina, where he visited Friday.</p><p>A talented technician, Geiger has the opportunity to cement himself as the top defensive back in the state in 2018.<br></p><p><b><a href="https://palmettopreps.rivals.com/subscriptions/new">*** Support PalmettoPreps.com by subscribing for as low as 27 cents/day now! ***</a><br></b><i><br></i></p>
</div>
</div>
<div class='text-center'>
<rv-share-links print-url='https://palmettopreps.rivals.com/news/geiger-shows-talent-at-carolina-xposure/printable' site-name='PalmettoPreps.com'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>

</div>
<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' enrichments='[{"active":true,"type":"Rivals","football":true,"list_id":null,"list_title":null,"position":1}]' is-super-admin='' ncaab-schedule-year='2017' ncaaf-schedule-year='2018' new-article-layout='true' scoreboard-photos-id='15154' scoreboard-scores-id='15153' site='{"id":128,"legacy_id":954,"name":"PalmettoPreps.com","friendly_name":"South Carolina HS Sports","annual_discount":null,"subdomain":"palmettopreps","primary_color":"001cc8","secondary_color":"f8f8f8","font_color":"ffffff","short_name":"palmettopreps","maple_ncaaf_team_id":null,"maple_ncaaf_endpoint":null,"maple_ncaab_team_id":null,"maple_ncaab_endpoint":null,"maple_college_id":null,"google_analytics_id":"UA-81901317-1"}' twitter-feed='{"id":127,"site_id":128,"handle":"PalmettoPrepsSC","list_name":"sc-high-school-football","created_at":"2016-02-01T12:25:24.053-06:00","updated_at":"2018-01-31T20:20:12.756-06:00","hashtags":[],"usernames":["PalmettoPrepsSC"],"max_number":null}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://palmettopreps.rivals.com/news/geiger-shows-talent-at-carolina-xposure/printable' site-name='PalmettoPreps.com'></rv-share-links>
</div>
</div>
</div>
<script>
  $(function () {
    if ('false' === 'true') {
      var comment = document.createComment("ads suppressed in development");
  
      document.body.appendChild(comment);
    }else{
      var ad_url = generateDarlaAdUrl('2022719679', 'https://palmettopreps.rivals.com/news/geiger-shows-talent-at-carolina-xposure');
  
      var script = document.createElement("script");
      script.src = ad_url;
  
      document.body.appendChild(script);
    }
  });
</script>

<script>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  var byline = document.querySelector('#byline');
  var onetimeAuthors = document.querySelector('#onetime-author');
  if (byline) { // Remove after completely transitioning to new layout (should definitely be done by Jan 1st 2018)
    var i = byline.innerText.indexOf('|');
    var author = byline.innerText.slice(0, i-1);
  } else if (onetimeAuthors) {
    // Possibly multiple authors
    var listAuthors = onetimeAuthors.innerText.split(/ ,| and/);
    var author = listAuthors.join(',');
  } else {
    var bylineNew = document.querySelector('.author-byline .title-sm');
    if (bylineNew) {
      var i = bylineNew.innerText.indexOf('•');
      var author = bylineNew.innerText.slice(0, i-1);
    }
  }
  function getAliasVariable() {
    var host = window.location.host.split('.');
    // add 'n' if it is a Site page
    if (_.include(['n', 'acceptance', 'local'], host[0].toLowerCase()) || host.length == 4) {
      if (_.include(['n'], host[0].toLowerCase())) { host.shift() } // If we are on nationals prod, drop the n subdomain from the alias (aka make it be just rivals.com)
      return host.join('.') + window.location.pathname
    } else {
      host.splice(1, 0, 'n');
      return host.join('.') + window.location.pathname
    }
  }
  _sf_async_config.section = 'article';
  _sf_async_config.authors = (byline || bylineNew || onetimeAuthors) ? author : '';
  _sf_async_config.alias = getAliasVariable();
  _sf_async_config.title = "Geiger shows talent at Carolina Xposure";
  _sf_async_config.sections = 'content,content-football,content-football-free,content-article';
  /** CONFIGURATION END **/
  function loadChartbeat() {
    window._sf_endpt = (new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
    document.body.appendChild(e);
  };
</script>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if="showLRECad('footer')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
</div>
<div class='OUTBRAIN' data-ob-template='Rivals.com' data-src='https://palmettopreps.rivals.com' data-widget-id='AR_4'></div>
<script src='https://widgets.outbrain.com/outbrain.js' type='text/javascript'></script>
</div>

</div>
</main>
<footer>
<ul class='footer-links list-inline'>
<li>
<a href='https://n.rivals.com/news/about-us'>About</a>
<a href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
<a href='https://policies.yahoo.com/us/en/yahoo/ip/index.htm'>Copyright/IP Policy</a>
<a href='https://n.rivals.com/news/contact-us-5'>Contact Us</a>
<a href='/tos'>Terms of Service</a>
<a href='https://n.rivals.com/news/member-services'>Member Services</a>
</li>
</ul>
<div class='copyright-notice'>&copy; Yahoo! Inc.</div>
</footer>
</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022719679",
    c7: "https://palmettopreps.rivals.com/news/geiger-shows-talent-at-carolina-xposure"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://s.yimg.com/lq" : "http://l.yimg.com/d") + "/lib/3pm/cs_0.2.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Fpalmettopreps.rivals.com%2Fnews%2Fgeiger-shows-talent-at-carolina-xposure&c5=2022719679&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

</html>
