<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"21817424,115551496","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":2,"applicationTime":191,"agent":""}</script>
<script>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</script>
<!-- GUCE -->
<meta content='false' name='oath:guce:product-eu'>
<meta content='guce.rivals.com' name='oath:guce:consent-host'>
<script src="https://s.yimg.com/oa/guce.js" async="async"></script>
<script>
  var googleAnalyticsId = "UA-81901317-1";
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
  ga('create', googleAnalyticsId, 'auto');
</script>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<link href='https://cdn.rivals.com/production/assets/YahooSansFonts-7bf9e355b46ff060654c148212a35d40cb49b73381f27a9833dcc432fff1c97a.css' rel='stylesheet'>
<script src="https://cdn.rivals.com/production/packs/js/application-470fcb83c674e4c58e70.js"></script>
<link rel="stylesheet" media="screen" href="https://cdn.rivals.com/production/packs/css/application-f351f94b.css" />
<title>PalmettoPreps  -  South Carolina high school football recruitin...</title>
<meta content='PalmettoPreps  -  South Carolina high school football recruitin...' property='og:title'>

<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-02eb9b5f2c94db113dfb318987ff62b83675833797c26696434b80eefa9d2109.css" />


<script src="https://cdn.rivals.com/production/assets/lib-12381f29bb2a6e1cd6ab2484aa7e729e8f72a6f1457e3a239ac156581f11a919.js"></script>
<script src="https://cdn.rivals.com/production/assets/application-ca9375cb00157a94fb9145cdc52b8a8b269ffbbc606ad5f3cc60aef1d1a15362.js"></script>

<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="nczszEMoZ6UXYMGe+h7zp+dSPwSugDxWzot/quww5HqslMXLygYxA+RuPt7d5E4iFW/WxjEv0ht90XrnNRTnCw==" />
<script>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</script>
</script>

<script>
  (function () {
    'use strict';
    angular.module('rivals').factory('baseAppSettings', function () {
  
      var getPremiumIcon = function() {
        return "";
      };
  
      return {
        getPremiumIcon: getPremiumIcon
      };
    });
  }).call(this);
</script>

<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-273d00a84d0505fdc2d9beb1315850199c1ab215394a98be1a63372ca20207de.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-bbea1de48acc36b36c4ecbc46ec3289e31950d22f6370c08529de09bfece57b8.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://palmettopreps.rivals.com/news/palmettopreps-com-s-south-carolina-high-school-football-recruiting-notebook-2-copy-2183' property='og:url'>
<meta content='https://cdn.rivals.com/image/upload/f_auto,q_auto,t_headline_primary/ehfavsyzz07jku7zgfzc' property='og:image'>
<meta content='An end of June update with the latest recruiting happenings around SC  high school football prospects.' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2019-06-27 08:38:52 -0500' property='article:published_time'>
<meta content='2019-06-27 08:40:52 -0500' property='article:modified_time'>
<meta content='Article' property='article:section'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-7404e8851b384e973afdb1115390a36947dbf5fe28a232d84e5c6908cd7705d5.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-6648de94c2c3e41f6513ac5c0467ffd19f7c02e65a0fc936f1a9982f3ed748c8.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-8f5bdbc6adbf0c5fba8e0fcac9577fd4d33e68420787ee56f609e500a58b921f.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-6fe5688966b66892f842e9c4a9024cbca3c4cb1924d64c8d62a0ddbf47fc68e9.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-0372b897e5d8e989c1aeb7b4c620e3a3d1d7ce7406faf9ba0bfa6848c33b920a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-783a1158ba513dae40547a7466182cab45cdd11c5d875c25c4c47b5da51c027e.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-8241e0d11a6d3b792f7ff1728e23e8d3d4c06a582e090d29c3dd0e3c075a9105.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-7882a3d3bb9b9b3b702c4e642b2c161e2efc0e47150051764e987199e58bd8c0.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-07196b8cded86c2a4bf5c14f585d72da8fb6c20c3246efc59fa27678059c9940.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-8f32636231ae820b22a672b74aedfff6c3106cccaeb865a002330d943f6910f4.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-c81451fd0d87890abd08b9db0a795d10339bb7c12662e9e9f3c15ac330bdaf9a.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-8df131d801eebf824632ce95b824704d0a928c3cf453c5222cbe555c87b1eb0f.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-728b6833bcd8ec9ff9fa15aba3595de5b9df51530f29547457c749719f1f0b8d.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-e7e88ca08f6e98bf706fceb62b57f86c338da64c83252bcc5a8b2f35fd89f191.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-5ab6bada83e2c243aec32edcf5f419498d7897c6cfcca56ba6b1a16c7091f14d.json' rel='manifest'>
<script>
  var _sf_async_config = _sf_async_config || {};
  var subdomain = "palmettopreps.rivals.com";
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63621; // ACCOUNT NUMBER
  _sf_async_config.domain = subdomain;
  _sf_async_config.flickerControl = false;
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>

</head>
<body class='palmettopreps contents-show' ng-app='rivals'>
<script>
  angular.module('rivals').run(function(googleAnalyticsService) {
    googleAnalyticsService.setGaClientId();
    })
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  /*doc
     ---
     title: Yahoo Heading & Body
     category: typography
     ---
   ```haml_example
  .font-yahoo-h2 Font Yahoo H2
  .font-yahoo-h3 Font Yahoo H3
  .font-yahoo-h4 Font Yahoo H4
  
  .font-yahoo-b4 Font Yahoo B4
  .font-yahoo-b5 Font Yahoo B5
   ```
  */
  @media screen and (max-width: 1023px) {
    .palmettopreps #programming > h1 {
      background-color: #001cc8 !important; } }
  .palmettopreps .wrapper-container .team-colors-line {
    background-color: #f8f8f8; }
  .palmettopreps .team-colors-line {
    width: 100%;
    height: 8px;
    display: flex;
    background-color: #001cc8; }
    .palmettopreps .team-colors-line .color {
      width: 33.33%; }
    .palmettopreps .team-colors-line .first-opacity {
      background-color: white;
      opacity: 0.2; }
    .palmettopreps .team-colors-line .second-opacity {
      background-color: white;
      opacity: 0.4; }
    .palmettopreps .team-colors-line.vertical {
      flex-direction: column;
      height: auto;
      width: 8px; }
      .palmettopreps .team-colors-line.vertical .color {
        width: 100%;
        height: 33.33%; }
    .palmettopreps .team-colors-line.header {
      height: 6px; }
  .palmettopreps > header .notification-link .count-container {
    background-color: #001cc8 !important; }
  .palmettopreps > header .wrapper-container {
    background-color: #001cc8 !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .palmettopreps > header .wrapper-container {
        border-bottom: 6px solid #f8f8f8 !important; } }
  .palmettopreps > header .invalid-email-banner {
    background-color: #001cc8;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .palmettopreps > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .palmettopreps > header .invalid-email-banner a:hover {
      color: #f8f8f8; }
  @media screen and (max-width: 767px) {
    .palmettopreps > header .mobile-header {
      background-color: #f8f8f8 !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  .palmettopreps > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  .palmettopreps > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  .palmettopreps > header .second-nav {
    background-color: white !important; }
  @media screen and (max-width: 1023px) {
    .palmettopreps > header .nav-row > ul,
    .palmettopreps > header .third-nav {
      background-color: white !important; }
    .palmettopreps > header .dropdown-toggle > i.fa {
      color: #001cc8 !important; } }
  .palmettopreps > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #001cc8; }
  
  .site-primary-font-color {
    color: #001cc8; }
  
  .site-primary-background-color {
    background-color: #001cc8; }
  
  .site-secondary-font-color {
    color: #f8f8f8; }
  
  .site-secondary-background-color {
    background-color: #f8f8f8; }
  
  .team-background-image {
    background-image: linear-gradient(rgba(0, 28, 200, 0.4), rgba(0, 28, 200, 0.4)), url();
    background-repeat: no-repeat;
    background-position: center; }
  
  :root {
    --primary-color: #001cc8;
    --secondary-color: #f8f8f8;
    --accent-color: #001cc8;
    --button-color: #001cc8; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-cloak ng-controller='NavController as ctrl' ng-init='ctrl.init(false)' role='navigation'>
  <div class='wrapper-container'>
    <div class='wrapper logo-row'>
      <a alt="Rivals" href="https://rivals.com"><div class='rivals-logo-navbar-white'></div>
      </a>
      <a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
      <a alt="South Carolina HS Sports" class="site-header" ng-class="ctrl.teamSite ? &quot;team&quot; : &quot;no-team&quot;" href="https://palmettopreps.rivals.com/"><span class='header-text'>
        PalmettoPreps
      </span>
      </a>
      <div class='nav-right-controls'>
        <div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
          <span class='upsell-text'>
            Join the team!
          </span>
          <a ng-href='{{ ctrl.subscribePath }}'>
            Subscribe
          </a>
        </div>
        <rv-universal-search></rv-universal-search>
        <rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
        <rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && !ctrl.isMobile'></rv-forums-info>
      </div>
    </div>
  </div>
  <div class='mobile-header'></div>
  <rv-header-alert class='alert-nav' scroll-min='40'></rv-header-alert>
  <hr>
  <div class='nav-row-container'>
    <div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://palmettopreps.rivals.com/">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;palmettopreps&#39;" limit="8"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://palmettopreps.rivals.com/">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;palmettopreps&#39;" limit="4"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
      <a ng-href='{{ctrl.userProfileEditPath}}'>
        Your account has an invalid email address. Please update it here.
      </a>
    </div>
  </div>
</nav>
</header>
<div class='alert-placeholder'>
<rv-header-alert class='alert-nav'></rv-header-alert>
</div>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script>
  YAHOO.i13n.WEBWORKER_FILE = "js/rivals/analytics/rapidworker-1.2.js";
  
  var rapid = new YAHOO.i13n.Rapid({
    spaceid: 2022719679,
    ywa: {
      project_id: 10002066977754,
      document_group: 'content',
      member_id: 0
    },
    nol: 1,
    client_only: 1
  });
</script>

<script>
  var contentTitle = "South Carolina high school football recruitin..."
</script>
<meta content='summary_large_image' name='twitter:card'>
<meta content='palmettoprepssc' name='twitter:site'>
<meta content='South Carolina high school football recruitin...' name='twitter:title'>
<meta content='An end of June update with the latest recruiting happenings around SC  high school football prospects.' name='twitter:description'>
<meta content='https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/ehfavsyzz07jku7zgfzc' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init(nil, {"id":128,"legacy_id":954,"name":"PalmettoPreps","friendly_name":"South Carolina HS Sports","annual_discount":null,"subdomain":"palmettopreps","primary_color":"001cc8","secondary_color":"f8f8f8","font_color":"ffffff","short_name":"palmettopreps","maple_ncaaf_team_id":null,"maple_ncaaf_endpoint":null,"maple_ncaab_team_id":null,"maple_ncaab_endpoint":null,"maple_college_id":null,"google_analytics_id":"UA-81901317-1"}, true, 104, nil, {"id":20,"primary_color":"001cc8","secondary_color":"f8f8f8","font_color":"ffffff","commitment_module_football":false,"rivals_module_football":true,"header_name":null,"header_logo_cloudinary":null,"mobile_header_logo_cloudinary":null,"google_analytics_id":"UA-81901317-1","logo_background_shading":"white","football_content":true,"basketball_content":true,"baseball_content":true,"other_content":true,"site_id":128,"created_at":"2016-11-23T13:38:41.674-06:00","updated_at":"2019-01-14T19:00:06.143-06:00","max_trending_articles":6,"enrichments":[{"active":true,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"Rivals","football":true,"list_id":null,"list_title":null,"position":3},{"active":true,"type":"ScoreboardScores","football":null,"list_id":null,"list_title":null,"position":1},{"active":false,"type":"Commitment","football":false,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"Schedule","football":false,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"ScoreboardPhotos","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"TeamRankings","football":true,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"FanFuturecastLeaderboard","football":null,"list_id":null,"list_title":null,"position":null}],"footer_text":null,"sections":[],"supplied_domain":null,"message_board_link_url":"https://palmettopreps.forums.rivals.com","scoreboard_scores_id":15153,"scoreboard_photos_id":15154,"aol_player_id":null,"aol_company_id":null,"ad_frequency":5,"display_twitter_follow":true,"display_fb_follow":true,"follow_twitter_handle":"palmettoprepssc","follow_fb_handle":"PalmettoPrepsSC","forum_id":null,"premium_forum_id":null,"facebook_page_id":null,"max_ticker_articles":7,"schedule_header_on":true,"promo_popup_on":false,"facebook_developer_id":null,"customized_tos":[],"show_survey_popup":false,"survey_popup_link":null,"header_bottom_border_style":"solid","premium_icon_url":null,"customized_upsell_banner_text":null},&#x000A;"58e686759efa8936610b8215", "58e68374c7480e728bcc385f", "rivals", 15000, false, {"id":1796,"user_id":1074096,"site_id":128,"updated_at":"2017-08-14T15:18:40.756-05:00","publisher_name":"Chris Clark","first_name":"Chris","last_name":"Clark","site_title":"Publisher","bio":null,"twitter_handle":null,"image_url":null,"publisher_name_and_title":"Chris Clark, Publisher","site_name":"PalmettoPreps","site_short_name":"palmettopreps","has_edited_profile":false})'>

<div class='article-container' ng-class='{"no-ad-padding": "#{@display_ldrb_top}"}'>
<div class='upsell-forecast-banner' ng-cloak='true'>
<rv-user-forecast-banner class='forecast-banner' upsell='true'></rv-user-forecast-banner>
</div>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header'>
News
<a href="/more_news#other-news"><span class='more-news-link'>
More News
</span>
</a></div>
<rv-news-ticker contents='newsList' is_preview='false' is_publisher='isPublisher' premium_icon='null' profile_page='false' referral_code='referralCode' team='false'></rv-news-ticker>
</div>


<rv-message-boards ad-referer='https://palmettopreps.rivals.com/news/palmettopreps-com-s-south-carolina-high-school-football-recruiting-notebook-2-copy-2183' base-api-url='https://palmettopreps.forums.rivals.com/' homepage='false' message-board-url='https://palmettopreps.forums.rivals.com' pub-ad='null' size='size' space-id='2022719679' subscribed-user='subscribedUser'></rv-message-boards>

<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>
</div>
</div>
<div class='article-display-wrapper'>
<div class='article-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://palmettopreps.rivals.com/news/palmettopreps-com-s-south-carolina-high-school-football-recruiting-notebook-2-copy-2183/printable' site-name='PalmettoPreps'></rv-share-links>
</div>
<span class='article-header-age' ng-cloak>{{ timeAgo('2019-06-27 08:38:52 -0500') }}</span>
<span class='article-header-sport'>football</span>
<a class='edit-article updated-article-page' href='{{editPath(publishedSite)}}//publishing/contents/2055623/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h2 class='article-title'>South Carolina high school football recruitin...</h2>
<div class='header-image'><figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init="ctrl.init('https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/ehfavsyzz07jku7zgfzc','https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto/ehfavsyzz07jku7zgfzc')">
<div class='blurred-image'>
<div class='background' style='background-image: url(https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/ehfavsyzz07jku7zgfzc)'></div>
<div ng-class='{"clickable-image": ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img src="https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/ehfavsyzz07jku7zgfzc" alt="Ehfavsyzz07jku7zgfzc" />
<div class='zoom-image'></div>
</div>
</div>
</figure>
</div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<span>
<span class='author-name'>
Chris Clark
&bull;
</span>
<span class='type-sm'>PalmettoPreps</span>
</span>
</div>
<div class='vertical-align link-button' ng-click='authorBio()' ng-cloak>
<div class='caret-down' ng-cloak ng-show='!expandProfile'></div>
<div class='caret-up' ng-cloak ng-show='expandProfile'></div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
<span>
<span class='author-name'>Publisher</span>
</span>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>

</div>
</div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><div class='st__content-block st__content-block--text article-text'>
<p>In this feature, PalmettoPreps.com fills up a notebook with the latest recruiting news on high school football prospects across the Palmetto State in this end of June update.</p><p>***</p><p>* Southside Christian LB <a href="https://n.rivals.com/content/prospects/2020/jackson-dorris-248768">Jackson Dorris</a> has picked up a scholarship offer from Presbyterian College.</p><p>* Also out of Southside Christian, QB <a href="https://n.rivals.com/content/prospects/2020/jw-hertzberg-248799">JW Hertzberg </a>nabbed an offer from Limestone.</p><p>* Hammond LB<a href="https://n.rivals.com/content/prospects/2020/saul-diaz-237243"> Saul Diaz </a>picked up his first offer, which came from North Greenville.</p><p>* Another Hammond product, 2022 RB <a href="https://n.rivals.com/content/prospects/2022/cj-stokes-237244">CJ Stokes</a>, picked up an offer from South Carolina after camping in Columbia.<br></p><p>* Spartanburg 2020 athlete <b>Jamare Benjamin</b> now carries an offer from Wofford.</p><p>* On July 10, Byrnes RB <a href="https://n.rivals.com/content/prospects/2020/rahjai-harris-183935">Rahjai Harris</a> plans on announcing his top 10 schools out of a substantial group of offers.</p><p>* Woodmont defensive lineman <b>Cam Donald</b> made his verbal commitment to Navy this week.</p><p>* Legion Collegiate Academy wide receiver <a href="https://n.rivals.com/content/prospects/2020/omarion-dollison-209987">OD Dollison</a> released a top six that includes East Carolina, Georgia State, Old Dominion, Akron, James Madison, and Western Kentucky. He plans a commitment on July 4.</p><p>* Oregon, Tennessee, and Virginia Tech have all now offered 2023 wide receiver <a href="https://n.rivals.com/content/prospects/2023/devin-hyatt-255826">Devin Hyatt</a> from Dutch Fork.</p><p>* Syracuse offered 2021 Greer OL <a href="https://n.rivals.com/content/prospects/2021/jaydon-collins-224259">Jaydon Collins</a>.</p><p>* Manning ATH <a href="https://n.rivals.com/content/prospects/2020/aaron-smith-248711">Aaron Smith </a>picked up an offer from SC State.<br></p><p>* Charlotte offered 2023 Greer QB <a href="https://n.rivals.com/content/prospects/2023/raheim-jeter-234711">Raheim Jeter</a> and landed a verbal commitment from Rock Hill's <a href="https://n.rivals.com/content/prospects/2020/anthony-jackson-jr-184336">Anthony Jackson Jr.</a></p><p>*** Want to pass along news to us for a future PalmettoPreps recruiting notebook? Let us know on Twitter (@PalmettoPrepsSC) or email us (palmettoprepsrivals@gmail.com)!</p><p>*** We are looking for sponsors to support our content (see the graphic at the bottom), and subscriptions help keep our website going! </p><p><a href="https://palmettopreps.rivals.com/sign_up">*** Totally new to PalmettoPreps.com? CLICK HERE TO SUBSCRIBE and SUPPORT!</a></p><p><a href="https://palmettopreps.rivals.com/subscriptions/new">*** Former subscriber or registered free user with us or anywhere else on the Rivals network? CLICK HERE TO SUBSCRIBE and SUPPORT!</a></p>
</div>
</div>
<div class='text-center'>
<rv-share-links print-url='https://palmettopreps.rivals.com/news/palmettopreps-com-s-south-carolina-high-school-football-recruiting-notebook-2-copy-2183/printable' site-name='PalmettoPreps'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>
</div>
<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' enrichments='[{"active":true,"type":"ScoreboardScores","football":null,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"Rivals","football":true,"list_id":null,"list_title":null,"position":3}]' is-super-admin='' is_schedule_football='true' ncaab-schedule-year='2018' ncaaf-schedule-year='2019' scoreboard-photos-id='15154' scoreboard-scores-id='15153' site='{"id":128,"legacy_id":954,"name":"PalmettoPreps","friendly_name":"South Carolina HS Sports","annual_discount":null,"subdomain":"palmettopreps","primary_color":"001cc8","secondary_color":"f8f8f8","font_color":"ffffff","short_name":"palmettopreps","maple_ncaaf_team_id":null,"maple_ncaaf_endpoint":null,"maple_ncaab_team_id":null,"maple_ncaab_endpoint":null,"maple_college_id":null,"google_analytics_id":"UA-81901317-1"}' twitter-feed='{"id":127,"site_id":128,"handle":"palmettoprepssc","list_name":"staff","created_at":"2016-02-01T12:25:24.053-06:00","updated_at":"2018-03-27T09:44:43.890-05:00","hashtags":[],"usernames":["PalmettoPrepsSC"],"max_number":null}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://palmettopreps.rivals.com/news/palmettopreps-com-s-south-carolina-high-school-football-recruiting-notebook-2-copy-2183/printable' site-name='PalmettoPreps'></rv-share-links>
</div>
</div>
</div>
<script>
  $(function () {
    if ('false' === 'true') {
      var comment = document.createComment("ads suppressed in development");
  
      document.body.appendChild(comment);
    }else{
      var ad_url = generateDarlaAdUrl('2022719679', 'https://palmettopreps.rivals.com/news/palmettopreps-com-s-south-carolina-high-school-football-recruiting-notebook-2-copy-2183');
  
      var script = document.createElement("script");
      script.src = ad_url;
  
      document.body.appendChild(script);
    }
  });
</script>

<script>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  var byline = document.querySelector('#byline');
  var onetimeAuthors = document.querySelector('#onetime-author');
  if (byline) { // Remove after completely transitioning to new layout (should definitely be done by Jan 1st 2018)
    var i = byline.innerText.indexOf('|');
    var author = byline.innerText.slice(0, i-1);
  } else if (onetimeAuthors) {
    // Possibly multiple authors
    var listAuthors = onetimeAuthors.innerText.split(/ ,| and/);
    var author = listAuthors.join(',');
  } else {
    var bylineNew = document.querySelector('.author-byline .title-sm');
    if (bylineNew) {
      var i = bylineNew.innerText.indexOf('•');
      var author = bylineNew.innerText.slice(0, i-1);
    }
  }
  function getAliasVariable() {
    var host = window.location.host.split('.');
    // add 'n' if it is a Site page
    if (_.include(['n', 'acceptance', 'local'], host[0].toLowerCase()) || host.length == 4) {
      if (_.include(['n'], host[0].toLowerCase())) { host.shift() } // If we are on nationals prod, drop the n subdomain from the alias (aka make it be just rivals.com)
      return host.join('.') + window.location.pathname
    } else {
      host.splice(1, 0, 'n');
      return host.join('.') + window.location.pathname
    }
  }
  _sf_async_config.section = 'article';
  _sf_async_config.authors = (byline || bylineNew || onetimeAuthors) ? author : '';
  _sf_async_config.alias = getAliasVariable();
  _sf_async_config.title = "South Carolina high school football recruitin...";
  _sf_async_config.sections = 'content,content-football,content-football-free,content-article';
  /** CONFIGURATION END **/
  function loadChartbeat() {
    window._sf_endpt = (new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
    document.body.appendChild(e);
  };
</script>

<div ng-controller='googleTagManagerController as ctrl' ng-init='ctrl.init("palmettopreps", 2055623, null)'>
<iframe height='0' ng-src='{{ ctrl.sourceUrl }}' referrerpolicy='origin' style='display:none;visibility:hidden' width='0'></iframe>
<noscript>
<iframe height='0' ng-src='{{ ctrl.sourceUrl }}' referrerpolicy='origin' style='display:none;visibility:hidden' width='0'></iframe>
</noscript>
</div>

<div class='article-ads-footer'>
<div class='lrec-ads'>
</div>
</div>

</div>
</main>
<div data-react-class="Footer/container" data-react-props="{}"></div>

</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022719679",
    c7: "https://palmettopreps.rivals.com/news/palmettopreps-com-s-south-carolina-high-school-football-recruiting-notebook-2-copy-2183"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://s.yimg.com/lq" : "http://l.yimg.com/d") + "/lib/3pm/cs_0.2.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Fpalmettopreps.rivals.com%2Fnews%2Fpalmettopreps-com-s-south-carolina-high-school-football-recruiting-notebook-2-copy-2183&c5=2022719679&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

</html>
